MYSQL的驱动类建议使用新的驱动类

MYSQL已经不推荐使用老的驱动类,希望能支持新的驱动类。
Loading class com.mysql.jdbc.Driver'. This is deprecated. The new driver class iscom.mysql.cj.jdbc.Driver’. The driver is automatically registered via the SPI and manual loading of the driver class is generally unnecessary.

或者允许用户指定驱动类,或者支持直接使用Spring管理的连接池

有没有尝试下载最新的 mysql 驱动进行替换?

说的就是新的MYSQL驱动,是你们代码里面把driverclass写死了,用的老驱动的class

确实是个问题,关于这个问题我在英文论坛上询问了,你可以关注这个问题的答复:

感谢回复!:grin:

看来是支持的,具体看一下英文论坛开发人员的回复。

在context.xml可以指定驱动类
driverClassName=“com.mysql.cj.jdbc.Driver”